Fixes for Sid Meier’s Civilization VI: Errors Tutorial

Series of RTS, Sid Meier’s Civilization, always been pretty popular project. Players were waiting with excitement all five games and sixth, Sid Meier’s Civilization VI, is not exception.

But when time has come, players encountered with different sorts of problems: errors, bugs, low FPS, laggy sound, crashes and etc.

Before we deal with the problems and their solutions, we recommend that you review the system requirements for the game.

Minimum system requirements

  • OS: Windows 7 64bit / 8.1 64bit / 10 64bit
  • Processor: Intel Core i3 2.5 Ghz or AMD Phenom II 2.6 Ghz or greater
  • Memory: 4 GB RAM
  • Hard drive: 12 GB or more
  • DVD-Rom: Required for disc-based installation
  • Video card: 1 GB DirectX 11 Video Card (AMD 5570 or Nvidia 450)

Recommended system requirements

  • OS: Windows 7 64bit / 8.1 64bit / 10 64bit
  • Processor: Fourth generation Intel Core i5 2.5 Ghz or AMD FX8350 4.0 Ghz or greater
  • Memory: 8 GB RAM
  • Hard drive: 12 GB or more
  • DVD-Rom: Required for disc-based installation
  • Video card: 2 GB DirectX 11 Video Card (AMD 7970 or Nvidia 770 or greater)

Now let’s look at the methods for solving these problems.

sid-meiers-civilization-6-11

Sid Meier’s Civilization VI Not starting on Windows 8

As has been clarified, in order to successfully run the Sid Meier’s Civilization VI on Windows 8, you must install some updates for it.

To check whether you have already these updates go to “Programs and Features” -> “View installed updates”.

Try to find in the list of update KB2919355 (800MB) and KB2919442 (about 10MB). If is not present get them from these links and set in the same order.

https://www.microsoft.com/en-US/download/details.aspx?id=42335

https://www.microsoft.com/en-US/download/details.aspx?id=421

Sid Meier’s Civilization VI Not starting

To solve the problem that the game did not start, you can try the following method.

Rename the following files in something like a ***. Dll.OLD

  • C:\Windows\System32\LightFX.dll
  • C:\Windows\SysWOW64\LightFX.dll
  • C:\Windows\SysWOW64\LightFXXPS.dll

Then try to run the game.

Error XINPUT1_3.DLL in Sid Meier’s Civilization VI

This error is almost plain text points out the problems with DirectX. Simply install or reinstall DirectX. You can download it from this link:

https://www.microsoft.com/en-US/download/details.aspx?id=35

Error Api-ms-win-crt-runtime-L1-1-0.dll in Sid Meier’s Civilization VI

This error shows us that the root of the problem lies in the libraries Microsoft Visual C ++. As in the previous section on DirectX, download and install Visual Studio 2015. You can do this with the following links:

http://download.microsoft.com/download/9/3/F/93FCF1E7-E6A4-478B-96E7-D4B285925B00/vc_redist.x64.exe

Laggy sound in Sid Meier’s Civilization VI

It seems that the sound in the gamefor some players may behave quite strangely. It may make some odd sound, the logo of the game completely out of sync, etc.

To correct this problem, you should go to “Task Manager” -> “Sound” -> your playback device -> “Advanced”. Choose the “Default Format” -> “2 channel, 16 bit, 44100 Hz.”

After these settings, the sound in the game should return back to normal.

Low FPS in Sid Meier’s Civilization VI

Perhaps you could not play in this turn-based strategy because of the low FPS and twitches. Try the following steps to raise the performance of the game:

  • For holders of cards from AMD: try disabling Raptr from Task Manager. Also, turn off all unnecessary processes running on the computer. This should raise the performance of the game.
  • For holders of cards from Nvidia: Go to “Manage Settings 3D” -> “Power management mode”. Set the value “preferred mode of maximum performance”.
  • If you are experiencing a variety of screen flicker and FPS problems, try disabling Crossfire / SLI. Also try turning off Steam overlay in the game.

Found a mistake? Highlight the text and press Ctrl + Enter

4

4

Rating:
1 Star2 Stars3 Stars4 Stars5 Stars
Loading...
2 Comments
  1. Slavko 26.10.2016 in 13:33

    I installed visual studio 2015 and I still get that api problem .. I also downloaded that dll and added it in system32 and systemWOW64 and I still have the same problem ..

    Reply
  2. admsuper 26.10.2016 in 16:10

    You can try to install this update https://support.microsoft.com/en-us/kb/2999226.
    If it doesn’t help… well… the only thing you need to do, it just wait for patch from developers.

    Reply
Leave a Reply

Your email address will not be published.