Vulkan causing ERR_GFX_STATE crashes

Hello,Ever since the Moonshiners patch came out, the Vulkan API has been causing ERR_GFX_STATE to crash the game like crazy, even MORE than before. And not just for me. https://www.reddit.com/r/PCRedDead/comments/ebwhnp/are_they_ever_going_to_fix_err_gfx_state/https://steamcommunity.com/app/1174180/discussions/0/1750142582988698701/https://www.reddit.com/r/reddeadredemption/comments/dw82ez/crashes_texture_flickering_and_blurryness_after/https://www.reddit.com/r/PCRedDead/comments/dwhqx1/err_gfx_state_crash_on_vulkan/https://www.reddit.com/r/PCRedDead/comments/eadapo/new_err_gfx_state_error/The only way to launch the game after it breaks it, is to delete the SGAs and the settings.xml in the Documents folder. Another SORTA fix is switching via the settings.xml to DX12, but this API has crap performance, especially to us AMD users. It also gives us a ton of artifacting, which is a double negative to switching APIs. Please, look into the issue and help us. The game is unplayable! 🙁

1
Leave a Reply

avatar
newest oldest most voted

https://www.amd.com/en/support/kb/faq/gpu-601

Try running a radeon driver cleaner
========================

1 Close the application.
2 delete the c: / drive / documents / rs folder
3 Uninstall the radeon software
4 Download and install.  The 19.11.3 driver
Enjoy game.
========================

There isn’t proper formatting? And no edit button? Okay then. lol

Posting another temp fix. After deleting the settings.xml, change it to read only. You can keep Vulkan then. It will still provide the error, but then you can just delete the sgas and boot into the game. It obviously isn’t a good solution, just something I hope helps some people until Rock Star fixes the problem.